Unable to Overwrite Product Images

When we update a product’s images using PAM and /WebImages, the updated images are not visible on the site. If we add product images to a product that has never had an image, then the images post to the site just fine… The updated images are visible in our /WebImages directory, so they are being updated locally, but those updates are not posting to our site, or the CDN is not updating the image files. Something like that…

In some cases (see this product: http://nwca.com/1x8-HDMI-Powered-Splitter-HD-23108/) the images appear to be updated, yet hovering over the primary image shows the old product image as the ‘LargeDefault’ image.

Basically, we are unable to update our product images.

Things I’ve Tried:

  • Delete the images in /WebImages, then add the new images
  • Purge the Cache Tables (ProductImages)

Neither solutions have worked. Please advise.

1 Like

Hi Derek, I have also experienced this issue. The images do eventually update, but is in no way imediate, even if you purge the cache.

Hi Derek,

Are you changing the image name when you update the image? If you replace the file with the same name you won’t trigger distribution of the file on the CDN.


Hi @angela_morton, thanks for the info! Do you recall about how long the update takes? We waited a solid 24 hours for ours to refresh itself…

Hi @brendan! At what point would I change the image name (before adding to PAM)? We have the image name set to the ILC# (.jpg). We want to maintain that file naming convention…

If we can’t update product images without having to do a bunch of tinkering, then maybe this process should be reviewed, yeah? Perhaps a “Refresh/Reindex CDN” button that would allow us customers to purge the CDN when necessary? It would be super if this just worked lol. Can it not check “Date Modified” data to see if the image has been changed?

@jbw, can you confirm there are no current CDN replication issues, please? Derek is reporting that images aren’t updating. He gives examples above.


@donogh @jbw I don’t know what the wait time would be for the CDN to refresh, but we were still not seeing changes for ~48hrs. We didn’t wait any longer than that, and we just updated them manually ourselves by:

  • Deleting ALL images for said product from /WebImages/1,2,3,4…
  • Running Sync
  • Purge Sync cache table for product images
  • Adding image via PAM
  • Commit PAM changes
  • Run Sync

Don’t know if this info helps, but I hope so! Thanks guys.

@brendan I’m guessing you are asking if we are changing the naming convention before we attempt to overwrite the images… We originally (months ago) added some images using the product name as the images’ filename, and we did eventually changed that setting to name the images with the ILC# as the filename. So there is a good chance that one or more of these images in question had a change in filename.

That shouldn’t be an issue though right?


I’m not seeing any issues with CDN replication. I’m also not seeing any evidence of images not propagating - everything looks good to me. Am I missing something obvious?


@jbw - The images did not refresh for around 48 hours. We made sure to clear our local caches and all that, and still the images on our site did not change to the new versions. We had to delete the images, Sync, then add them and Sync again in order for the images to update. I didn’t leave any unpropagated images. Even after doing that, some products had the new versions for some images, and the old images for others. So the products were not rendering the updated images completely.

Is there anyway we can get a “Refresh CDN” button to force the CDN to reindex/refresh? In case we do some massive update to our product images?

Hi Derek

The issue is the images do refresh automatically so if for some reason the images didn’t change on the CDN then having a force CDN refresh button wouldn’t make any difference.

There’s several layers of caching going on so it’s hard to say what happened given the issue isn’t reproducible right now. Please let me know if you experience this issue again and I’ll gladly investigate further.


@jbw - The CDN refreshes every 24 hours about yeah? We have encountered instances where we want to refresh those images much sooner than that. Primarily if we have a customer express interest in a certain product, and we direct them to our website. But then we notice that the image is not 100% top-notch, so we update the image, but it does not refresh.

Uncommon situation for your other users?- probably, but it has happened to us a few times. So if it is easy to implement, can you please provide us with a refresh button?

This seems to be a fairly common feature of other frameworks (see this page: http://support.volusion.com/article/cdn). This particular framework has the following features available for their customers:

  • CDN (Enable or Dsiable)
  • Refresh CDN Image Cache
  • Reset Photo Cache
  • Rebuild Search Index

Just some ideas for your developers to talk about. I would be happy with the ‘Enable/Disable’, ‘Refresh’ and ‘Reset Cache’. Food for thought I suppose. Thanks

Hey Derek,

The button would do the same process it already follows automatically. We really need to see a ‘live’ problem to be able to diagnose where it’s failing. There are multiple layers involved: the images are sync’d to our servers; we push them to Akamai’s NetStorage servers; then Akamai pushes the images to other NetStorage servers; finally, the edge servers serve the updated images from NetStorage.

Next time you experience a problem, please let us know and leave at least one ‘problem’ image in place.


same thing here. sync/purge doesn’t work, deleting old images from 1,2,3,RMS folder, i even went far as deleting the item completely from SOM and starting from scratch but no go. Any updates on this issue? As Angela said, the images eventually do update… but sometimes takes up to almost 2-3 days for it change. very frustrating bc we just hired an entry level designer and has to re edit photos on multiple occasions throughout the day, everyday.

We are experiencing similar issues at the moment when replacing images. Thumbnails refuse to update yet the larger images are updating correctly resulting in a mishmash of images on our product and listing pages. Is this likely to be related to the CDN issues discussed above?

Is there a workaround to force these to update?

@andy - You have to:

  • Delete the old images from your local WebImages directory
  • Run Sync
  • Copy the new image into the WebImages directory
  • Run Sync

This usually works for us :slight_smile:

Cheers for the reply Derek. I’ll give that a shot and cross my fingers :wink:

1 Like

If you have any issues, try changing the name of the image (locally) before adding it into WebImages. We’ve found that changing the naming convention in PAM from ILC => Description (or whatever it is) will also signal the framework that the CDN needs to be refreshed…

So if you have issues, try those two things :slight_smile: