Issue Mapping 'product_weblinxcustomnumber1'

Hi Guys,

I’ve done a bit of field mappings since we began using our store. I am pretty sure I am doing everything correctly, but I am having an issue getting a certain field mapped:

I have tried:

  1. NSc Sync > Configuration > Advanced > Field Mappings > Item > Add Field > (PAM Field | Standard Field - BOTH)
  • Remote Field Name: product_weblinxcustomnumber1
  • Field Source: nitroasl_pamtable.Stock_MN (float, NULL)

Note: Stock_MN was added to nitroasl_pamtable via SQL Query in Management Studio, but displays in PAM just fine…

Now back in the WebStore > Buy Panel template, I am attempting to display some html if ‘product[‘product_weblinxcustomnumber1’]’ is greater than ‘0’:

  {if (product['product_weblinxcustomnumber1'] gt 0)}
    <span class="warehouse">{product['product_weblinxcustomnumber1']}/{product['product_stock']} Stored @ Minnesota Warehouse</span>

Unfortunately, the snippet above does not work because ‘product[‘product_weblinxcustomnumber1’]’ always returns ‘0’ (when it should be returning numbers like ‘818’, ‘135’, ‘10.5’, etc.)

Forgot to mention that I do not receive any errors when I hit ‘Ok’ to add the field in NSc Sync (like the errors you get if the Remote Field Name is misspelled or invalid). Sync appears to accept the Remote Field Name/Field Source…

Not sure what I did, but this works now… I did nothing different. I ran Sync a few more times, and it worked.

Derek, FYI, the custom number fields are small ints as opposed to floats. If you map a float you’ll end up losing precision, or the value could overflow. Best to use a custom text field with a call to ROUND in the field mapping to have it display the way you’d like.