Parser Error - NSc Sync not connecting

On Friday last, following an AVG update that required a re-start, I got a pop up box on the desktop with ‘Parser Errror’. Since then, NSc Sync has not functioned. I’ve tried downloading the latest version but it won’t connect to the database machine. I have uninstalled AVG from both machines at this stage to see if that was the problem. The PC that this problem is occurring on is new and there are no memory shortage issues.

Hi there,

Did you download the software from the portal, or from, please? The very latest version is available here: WebSell Support - Download Area Maybe you can try that?

The next step is to run the software in debug verbose mode. That’s done with two command line switches: /debug /verbose. Based on the typical path, it would be the following (via Start > Run):

“C:\Program Files\NitroSell\NSc Sync - RMSSO\NScSync.exe” /debug /verbose

You can learn more here: Sending Detailed NSc Sync Debug Logs to NitroSell Support

We haven’t received this error report from anyone else so I’d guess it’s an issue with your POS data. Anyway, let’s see what the debug output tells us.

Kind regards,

Thanks for replying. I have tried that but the error message Parser Error popped up on the screen again. On exiting Nsc Sync the following message appeared “Access violation at address 0057B1ED in module NSc Sync. Read of address is 00000004”

I took the updated version of NSc Sync from a link sent via the ticket from Conor at Nitrosell.

Ticket here for reference: Please Sign In - WebSell Portal

Hi Eamon,

Are you definitely running Sync as a administrator, please? Is UAC enabled in Windows? Please try closing it, right-clicking the icon and choosing Run as Administrator.

To be honest, it pretty much has to be an issue with your machine because no other users have reported the error.

Out of interest, is PAM still working okay? (To rule out the database connection as a potential culprit.)


Hi Donagh,

Thanks for your replies. The PAM is working fine. I tried running as administrator but the same Parser Error cropped up. I wonder would Conor have a look at it remotely to see if he can spot what might be causing the problem?


Error was corrupt config file which was replaced, details in ticket.


We’re getting the exact same issue today. Could somebody please put the resolution to this problem in this thread?

I figured this out on my own. config.xml did get corrupted. Luckily, we had another Windows user on that workstation that had NSync set up, and I successfully copied the config.xml and profile.xml from the working Windows user to this one, and all is good.

The path for both of these files is:
c:\users[username]\appdata\roaming\Nitrosell\Nsc Sync\

If I didn’t have another working profile on that workstation, I probably could’ve solved this by deleting those files and re-entering all of our login and configuration data into NSync.

I’m having the same issue. I can’t import my web orders. I can’t click on the “Configuration” tab in NSc Sync without getting an Access violation at address 12900000. I’m only computer literate enough to do damage. Any help is appreciated. :slight_smile:

Hi Pat,

please join me in the remote session (I sent a link in the ticket) - I’ll fix the issue!


1 Like

Is there an easy fix for this?

Hi Kevin,

It really depends on the root cause. Would suggest opening a ticket so the support team can assist.